ERROR in ./~/firebase/app/shared_promise.js


I'm trying to create an Angular 2 App with AngularFire2

I was following this guide.

Everytime I try to import the AngularFireModule in my app module and then do AngularFireModule.initializeApp(config) in the imports I'm getting the following error when I try to run ng serve:

ERROR in ./~/firebase/app/shared_promise.js
Module not found: Error: Can't resolve 'promise-polyfill' in 
@ ./~/firebase/app/shared_promise.js 22:35-62
@ ./~/firebase/app/firebase_app.js
@ ./~/firebase/app.js
@ ./~/firebase/firebase-browser.js
@ ./~/angularfire2/angularfire2.js
@ ./~/angularfire2/index.js
@ ./src/app/app.module.ts
@ ./src/main.ts
@ multi webpack-dev-server/client?http://localhost:4200 ./src/main.ts
webpack: Failed to compile.

And this is how my package.json look like:

     "name": "xxxxx",
     "version": "0.0.0",
     "license": "MIT",
     "scripts": {
     "ng": "ng",
     "start": "ng serve",
     "build": "ng build",
     "test": "ng test",
     "lint": "ng lint",
    "e2e": "ng e2e"
  "private": true,
  "dependencies": {
    "@angular/common": "^2.4.0",
    "@angular/compiler": "^2.4.0",
    "@angular/core": "^2.4.0",
    "@angular/forms": "^2.4.0",
    "@angular/http": "^2.4.0",
    "@angular/platform-browser": "^2.4.0",
    "@angular/platform-browser-dynamic": "^2.4.0",
    "@angular/router": "^3.4.0",
    "angularfire2": "^2.0.0-beta.8",
    "core-js": "^2.4.1",
    "firebase": "^3.7.8",
    "rxjs": "^5.1.0",
    "zone.js": "^0.7.6"
  "devDependencies": {
    "@angular/cli": "1.0.0-rc.0",
    "@angular/compiler-cli": "^2.4.0",
    "@types/jasmine": "2.5.38",
    "@types/node": "~6.0.60",
    "codelyzer": "~2.0.0",
    "jasmine-core": "~2.5.2",
    "jasmine-spec-reporter": "~3.2.0",
    "karma": "~1.4.1",
    "karma-chrome-launcher": "~2.0.0",
    "karma-cli": "~1.0.1",
    "karma-jasmine": "~1.1.0",
    "karma-jasmine-html-reporter": "^0.2.2",
    "karma-coverage-istanbul-reporter": "^0.2.0",
    "protractor": "~5.1.0",
    "ts-node": "~2.0.0",
    "tslint": "~4.4.2",
    "typescript": "~2.0.0"
Problem courtesy of: bekamais


npm install promise-polyfill --save --save-exact

It works for me.

Solution courtesy of: Zafer


If you'd like to have the dependency saved as well in package.json, be sure to include the --save flag as well as the --save-exact.

npm install promise-polyfill --save --save-exact
Discussion courtesy of: Armando Hoyos
npm install promise-polyfill --save-exact

in your command prompt paste this command and run it, I had the same problem and "" this post helped me to resolve the problem.

Discussion courtesy of: M.Ramzan

The 'promise-polyfill' dependencie is missing in firebase npm package version 3.7.8, you can install 'promise-polyfill' or downgrade firebase package to 3.7.7.

Discussion courtesy of: jfx

This recipe can be found in it's original form on Stack Over Flow.